Agilent G4212B Setting calibration wavelength failed

Discussions about HPLC, CE, TLC, SFC, and other "liquid phase" separation techniques.

13 posts Page 1 of 1
Error 1036
I've tried everything suggested in the manual...cleaned the flowcell optical input/output, flushed the flowcell with isopropanol, then water. Only thing left is to replace the lamp (only 1040 h. on it). Any other suggestions?

Lab Advisor B.02.11 (308)
ChemStation B04.03-SP1 (87)

The calibration values are stored in ROM. Error could be because they are lost.
First solution: I'd try to reboot detector and run test from hand controller.
Second: Try to reload firmware, perhaps it will fix possible errors.


Tomasz Kubowicz
Are you the end-user or someone trying to service the detector?
What is the history on the detector? Has it been working great for months/years, then suddenly showed the error ?
Did you recently acquire it from an auction or online seller?

We see many defective detectors. Flash the firmware, as suggested with the correct version to see if that clears it (easy to do). Make sure the flow cell is filled with either pure HPLC grade ACN or pure HPLC water, then try and runa wavelength calibration test, also an intensity test. Two different factory lamps are available for that unit. One is good for 1000 hours, the other for 2000 or more hours. If an aftermarket lamp has been installed, then replace it.

Many times when these fail to correct the issue, it turns out to be the mainboard which requires replacement.
thank you both.
I got it in an auction, and am the end-user. no idea what the history was like, the log just says this error is recent. I am getting the firmware update now, and I do not have Instant Pilot. Looks like previous use was prior to the 2016 firmware update.
The auction markets are flooded with broken, abused HPLC instruments. Sellers with no formal training in using or servicing these modules are putting them up for sale to make quick cash. Many are described as "working", "refurbished" or just "used", but are in fact just broken modules being flipped by sellers for fast cash. Many have sat in unconditioned storage facilities for years (corrosion on the insides is good evidence) before being put up for sale. Others are just the broken modules put aside by the major pharma companies. Ebay has tons of these damaged modules and dishonest sellers (and of course plenty of dishonest sellers on the web in general). We get a lot of these "working and tested" described modules in our shop for repair estimates, bought by our customers via ebay, Dovebid or other sellers who tell us they got a "good deal" and then find out the $2K flow cell is broken (or missing), the main board is defective (common on the detectors and TCC units) or other problems exist costing more to repair than the unit is worth. Buyer beware and where possible, purchase from an experienced and knowledgeable seller.
I hear that.
Also got an old HP 1050, "tested", sold as-is. Need a new lamp, at the minimum (Low Illumination error). luckily that one was dirt cheap.

back to the G4212...I loaded the new firmware, still no dice. Same error 1036.

a couple weeks ago, I would turn it on (before I got a copy of chemstation), and status light would be yellow, indicating a 'not ready' state. then, I turned it on one day, and the light was red. So the board must've been fine a few weeks ago, and there haven't been any power outages.

prior to getting chemstation, I did try to route signal from analog out into another CDS, and may have dirtied the flowcell from a couple sample injections, I don't know if that has anything to do with it. I've already flushed it several times since.

What I can recommend is to use hand controller or Chemstation (do not use LabAdvisor) and check if lamps is working ok. So forget about recalibration and try to establish if detector is even ready to work. Of course the ideal situation is that after you turn detector on Lamp stays OFF (if you have option "At power ON switch lamp ON" perhaps that is the problem).
And then step by step I'd check if you can switch between OFF-Standby. And then check if you can switch lamp on.
It will help you to narrow it down a bit.


Tomasz Kubowicz
I don’t have the controller, and the control options are limited to on, off, and initialize (or something similar).
As stated earlier, the flow cell can cause calibration to fail. Do you have the 60 mm "MAX" flow cell? They break all of the time and are the number one reason you see sellers offering those flow cells for sale (most of the 60 mm path length cells are broken and worthless). If you have a conventional flow cell (10, 6 or 1 mm), then those are nearly indestructible and can be cleaned or repaired.
I have the standard 10mm, 1 uL Max-Light flowcell G4212-60008.
Thank you for the info regarding which flow cell you are using.

Please connect the module to LabAdvisor software to find out what the current errors are. Does it connect? If not, that is additional evidence that the main board may be the problem. This may save you from wasting money on parts you do not need (though you probably do need a fresh lamp). Speaking of the D2 lamp, is it a factory bulb? Bad bulbs will turn the RED status light on. The bulb may have been marginal when you got it, and has now failed. *A g4208A module will also provide you with good troubleshooting info and can be connected directly to the module. Newer versions of ChemStation no linger come with any diagnostic software (you did not say which version you are using).

To troubleshoot if the flow cell is the cause of one or more of the failures, please insert the Max-Light Cartridge Test Cell into the detector. Next, run the "Cell Test". This built-in test will ask you to place the test cell in position, then measure the lamp intensity. It will then ask you to place your flow cell in position (it will read the cell to see which type it is) and flow pure, fully degassed, HPLC grade water through it at 0.500 ml/min. A measurement of intensity will be made and compared to the test cell (ratio). We perform this test during a detector qualification as it provides us with a baseline value to compare the cell to for future reference. However, you can still use it w/o the initial baseline info to get an idea if the flow cell is contaminated.

*Most of the problems we see with these detector are the result of damaged Max-Light cartridges. They are very fragile and clients often fail to clean them of contamination and/or flush buffers from them after use every day. Spares are good to have on hand. *You mentioned that you initially cleaned it, then ran some samples through it. Try cleaning it again, just to be sure.
I mentioned the version of ChemStation in the OP.
I’ve cleaned the cartridge several times, but still get the error (which shows up after powering on the module). I am unable to clear the error in Lab Advisor, nor run any other tests, as the software will not permit this when the module is in an error state. The lamp is an agilent lamp, but may not be a long-life version. I have a replacement arriving today.
The lamp didn't fix the issue, so I caved and ordered an Instant Pilot.
13 posts Page 1 of 1

Who is online

In total there are 12 users online :: 0 registered, 0 hidden and 12 guests (based on users active over the past 5 minutes)
Most users ever online was 599 on Tue Sep 18, 2018 9:27 am

Users browsing this forum: No registered users and 12 guests

Latest Blog Posts from Separation Science

Separation Science offers free learning from the experts covering methods, applications, webinars, eSeminars, videos, tutorials for users of liquid chromatography, gas chromatography, mass spectrometry, sample preparation and related analytical techniques.

Subscribe to our eNewsletter with daily, weekly or monthly updates: Food, Environmental, (Bio)Pharmaceutical, Bioclinical, Liquid Chromatography, Gas Chromatography and Mass Spectrometry.

Liquid Chromatography

Gas Chromatography

Mass Spectrometry