Signal Buffer Server has stopped working

Discussions about chromatography data systems, LIMS, controllers, computer issues and related topics.

2 posts Page 1 of 1
We are using the old EZChrom Elite version 3.3.2 SP1 and an Agilent 7890B. This has been working very good for several years. Suddenly we get a problem now that keeps coming up. An error message pops up saying "Signal Buffer Server has stopeed working", and then all analysis fails. In the Event Viewer we can see text saying
"Faulting application name: hpsignalbufferservice.exe, version: 1.2.26.0, time stamp: 0x46d80633
Faulting module name: RPCRT4.dll, version: 6.1.7601.24000, time stamp: 0x5a49962d
Exception code: 0xc0000005 etc

Anybody know anything about this, and what the problem can be ?
Martin
Since we also supporting this instrument (http://www.unichrom.com/dle.php http://www.unichrom.com/ag7890/ag7890e.shtml) and knowing exactly what is signal buffer - probably the reason of your problem - you have removed (or EzChrom did it for you) from monitoring one of the signal. All the 4 GC signal buffers has to be exhausted continuously. If one of them is omitted - data buffer overruns and reports error.

Also the way GC responds with data make some specials.

Software subscribes to data channel and reports the IP and port of TCP listening server. GC connects to that server and sends data. When IP interface (network card IP addres and port) is blocked by firewall or taken by another program - you get the error. Try to minimize working program count, stop unnecessary services and, disable firewall (temporarily) and have a look to netstat -a (you get a list of listening TCP services of your machine).

For all the signals the listening sockets (netstat -a output) looks like:
TCP 0.0.0.0:10001 - that is signal 1 server
TCP 0.0.0.0:10002
TCP 0.0.0.0:10003
TCP 0.0.0.0:10004

Also if your PC has multiple network cards - may be a problem. Disable non-GC interface.

Also - one of the MS updates resolved RPC problem which EzChrom relies on. One of the XML field become empty string - and signal server crushes on dereferencing null pointer (0xC0000005)
2 posts Page 1 of 1

Who is online

In total there are 15 users online :: 0 registered, 0 hidden and 15 guests (based on users active over the past 5 minutes)
Most users ever online was 234 on Tue Feb 06, 2018 7:33 am

Users browsing this forum: No registered users and 15 guests